Skip to content

← Actionable
High, CVSS 7.5

Neos Information Disclosure Security Note

GHSA-3c5g-73f7-grvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (neos/neos 4.3.3, 4.2.12, 4.1.16, 4.0.17, 3.3.23, 3.2.14, 3.1.18, 3.0.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist neos/neos

    Affected
    >= 2.3.0, < 3.0.20>= 3.1.0, < 3.1.18>= 3.2.0, < 3.2.14>= 3.3.0, < 3.3.23>= 4.0.0, < 4.0.17>= 4.1.0, < 4.1.16>= 4.2.0, < 4.2.12>= 4.3.0, < 4.3.3
    Fixed in
    4.1.16, 3.1.18, 3.3.23, 3.0.20, 4.3.3, 3.2.14, 4.2.12, 4.0.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Due to reports it has been validated that internal workspaces in Neos are accessible without authentication. Some users assumed this is a planned feature but it is not. A workspace preview should be an additional feature with respective security measures in place. Note that this only allows reading of internal workspaces not writing. And for clarification, an internal workspace is a workspace that is non public and doesn't have an owner. Given that an internal workspace exists in your installation, it is possible to view a page in context of that workspace by opening a link in this format: https://domain/path/to/page.html@workspace-name The issue is quite problematic when exploited but at the same time slightly less impactful than it sounds. First of all there is no default internal workspace, so the issue affects only workspaces created by users. That also means the workspace-name, which will also always include a hash is individual to a project and an exploiter must get hold of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3c5g-73f7-grvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3c5g-73f7-grvm

Advisory: Neos Information Disclosure Security Note
IDs: GHSA-3c5g-73f7-grvm
Record: https://patchnext.com/advisories/ghsa-3c5g-73f7-grvm (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: neos/neos 4.3.3, 4.2.12, 4.1.16, 4.0.17, 3.3.23, 3.2.14, 3.1.18, 3.0.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist neos/neos: affected >= 2.3.0, < 3.0.20; >= 3.1.0, < 3.1.18; >= 3.2.0, < 3.2.14; >= 3.3.0, < 3.3.23; >= 4.0.0, < 4.0.17; >= 4.1.0, < 4.1.16; >= 4.2.0, < 4.2.12; >= 4.3.0, < 4.3.3; fixed in 4.1.16, 3.1.18, 3.3.23, 3.0.20, 4.3.3, 3.2.14, 4.2.12, 4.0.17

## Suggested inspection (read-only)
- Packagist neos/neos: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on neos/neos.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3c5g-73f7-grvm (GitHub-reviewed advisory GHSA-3c5g-73f7-grvm lists affected ranges: Packagist neos/neos >=2.3.0 =3.1.0 =3.2.0 =3.3.0 =4.0.0 =4.1.0 =4.2.0 =4.3.0 <4.3.3)

Commands are suggestions: review each one before running it.

Loading voting…