Ez Platform Object Injection in legacy shop module
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2019.3.5.1, 2017.12.7.3, 5.4.14.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezpublish-legacy
- Affected
- >= 2019.3.0, < 2019.3.5.1>= 2017.12.0, < 2017.12.7.3>= 5.4.0, < 5.4.14.2
- Fixed in
- 2017.12.7.3, 5.4.14.2, 2019.3.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-39j2-4p9j-5w4j lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2019.3.0 =2017.12.0 =5.4.0 <5.4.14.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This Security Advisory is about a vulnerability in the Legacy shop module. A backend editor could perform object injection in discount rules. This would require backend access and permission to edit discount rules. While object injection in itself is a serious vulnerability, the permission requirement means that normally only administrators would be able to exploit it, that's why it was classified as Medium severity.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-39j2-4p9j-5w4j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-39j2-4p9j-5w4j Advisory: Ez Platform Object Injection in legacy shop module IDs: GHSA-39j2-4p9j-5w4j Record: https://patchnext.com/advisories/ghsa-39j2-4p9j-5w4j (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2019.3.5.1, 2017.12.7.3, 5.4.14.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezpublish-legacy: affected >= 2019.3.0, < 2019.3.5.1; >= 2017.12.0, < 2017.12.7.3; >= 5.4.0, < 5.4.14.2; fixed in 2017.12.7.3, 5.4.14.2, 2019.3.5.1 ## Suggested inspection (read-only) - Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezpublish-legacy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-39j2-4p9j-5w4j (GitHub-reviewed advisory GHSA-39j2-4p9j-5w4j lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2019.3.0 =2017.12.0 =5.4.0 <5.4.14.2) Commands are suggestions: review each one before running it.
Loading voting…