Skip to content

← Actionable
High, CVSS 8.2

Pingora update for MadeYouReset HTTP/2 vulnerability

GHSA-393w-9x6h-8gc7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pingora-core 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Pingora deployments that include HTTP/2 server support may be affected by the vulnerability described in CVE-2025-8671. Under certain conditions, Pingora applications may allocate buffers before the HTTP/2 reset and resulting stream cancellation is processed by the server. Repeated resets can force excessive memory consumption and lead to denial-of-service. Impact: On affected versions, malicious clients could trigger unusually high memory consumption, which may result in service instability or process termination. Credits: Reported responsibly by security researcher Gal Bar Nahum (@galbarnahum) Mitigation: This issue is addressed by ensuring Pingora uses patched versions of HTTP/2 dependencies that include reset-handling safeguards to release connection resources before excessive memory buildup. Users should upgrade to the latest Pingora release, which incorporates the required fixes. - Users are requested to upgrade to latest version of Pingora = 0.6.0

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-393w-9x6h-8gc7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-393w-9x6h-8gc7

Advisory: Pingora update for MadeYouReset HTTP/2 vulnerability
IDs: GHSA-393w-9x6h-8gc7
Record: https://patchnext.com/advisories/ghsa-393w-9x6h-8gc7 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pingora-core 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io pingora-core: affected < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io pingora-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pingora-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-393w-9x6h-8gc7 (GitHub-reviewed advisory GHSA-393w-9x6h-8gc7 lists affected ranges: crates.io pingora-core >=0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…