Skip to content

← Actionable
Medium, CVSS 6.8amended

Veramo is Vulnerable to SQL Injection in Veramo Data Store ORM

GHSA-38cw-85xc-xr9x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@veramo/data-store 6.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary An SQL injection vulnerability exists in the @veramo/data-store package that allows any authenticated user to execute arbitrary SQL queries against the database. The vulnerability is caused by insufficient validation of the column parameter in the order array of query requests. Details packages/data-store/src/data-store-orm.ts (lines 416-434) The vulnerability exists in the decorateQB() function which processes query ordering parameters: Root Cause: 1. The item.column value from user input is passed directly as the alias parameter to addSelect() without any sanitization or validation 2. While TypeScript defines allowed column types (e.g., TCredentialColumns = 'context' | 'type' | ...), this is only compile-time checking 3. At runtime, the function accepts FindArgs<any, allowing arbitrary strings to bypass type restrictions 4. TypeORM inserts the alias directly into the SQL query, enabling SQL injection Affected Endpoints: All endpoints are located in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-38cw-85xc-xr9x

  2. Revision 1 · created ·

    Published from osv record GHSA-38cw-85xc-xr9x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-38cw-85xc-xr9x

Advisory: Veramo is Vulnerable to SQL Injection in Veramo Data Store ORM
IDs: GHSA-38cw-85xc-xr9x
Record: https://patchnext.com/advisories/ghsa-38cw-85xc-xr9x (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @veramo/data-store 6.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @veramo/data-store: affected < 6.0.2; fixed in 6.0.2

## Suggested inspection (read-only)
- `npm ls @veramo/data-store --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @veramo/data-store.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-38cw-85xc-xr9x (OSV record GHSA-38cw-85xc-xr9x lists affected ranges: npm @veramo/data-store >=0 <6.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-38cw-85xc-xr9x (GitHub-reviewed advisory GHSA-38cw-85xc-xr9x lists affected ranges: npm @veramo/data-store >=0 <6.0.2)

Commands are suggestions: review each one before running it.

Loading voting…