Skip to content

← Actionable
High, CVSS 7.1

SurrealDB memory exhaustion via string::replace using regex

GHSA-3633-g6mg-p6qq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 2.2.2, 2.1.5, 2.0.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io surrealdb

    Affected
    >= 2.2.0, < 2.2.2>= 2.1.0, < 2.1.5< 2.0.5
    Fixed in
    2.1.5, 2.2.2, 2.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

An authenticated user can craft a query using the string::replace function that uses a Regex to perform a string replacement. As there is a failure to restrict the resulting string length, this enables an attacker to send a string::replace function to the SurrealDB server exhausting all the memory of the server due to string allocations. This eventually results in a Denial-of-Service situation for the SurrealDB server. This issue was discovered and patched during an code audit and penetration test of SurrealDB by cure53. Using CVSSv4 definitions, the severity is High. Impact An authenticated user can crash the SurrealDB instance through memory exhaustion Patches A patch has been created that enforces a limit on string length SURREALGENERATIONALLOCATIONLIMIT - Versions 2.0.5, 2.1.5, 2.2.2, and later are not affected by this issue Workarounds Affected users who are unable to update may want to limit the ability of untrusted clients to run the string::replace function in the affected…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3633-g6mg-p6qq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-3633-g6mg-p6qq

Advisory: SurrealDB memory exhaustion via string::replace using regex
IDs: GHSA-3633-g6mg-p6qq
Record: https://patchnext.com/advisories/ghsa-3633-g6mg-p6qq (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: surrealdb 2.2.2, 2.1.5, 2.0.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io surrealdb: affected >= 2.2.0, < 2.2.2; >= 2.1.0, < 2.1.5; < 2.0.5; fixed in 2.1.5, 2.2.2, 2.0.5

## Suggested inspection (read-only)
- crates.io surrealdb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on surrealdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3633-g6mg-p6qq (GitHub-reviewed advisory GHSA-3633-g6mg-p6qq lists affected ranges: crates.io surrealdb >=2.2.0 =2.1.0 =0 <2.0.5)

Commands are suggestions: review each one before running it.

Loading voting…