Skip to content

← Actionable
Medium, CVSS 6.5amended

Dulwich: Infinite Loop Denial of Service (DoS) in Packfile Object Resolution

CVE-2026-114095GHSA-35mr-4567-66vg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dulwich 1.2.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dulwich

    Affected
    < 1.2.9
    Fixed in
    1.2.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-114095: 0.31% estimated exploitation activity in the next 30 days; percentile 23.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected file dulwich/pack.py (Method: Pack.resolveobject) Description / Summary A High-severity Denial of Service (DoS) vulnerability exists in the Pack.resolveobject method. When resolving an OFSDELTA object, the resolver calculates the base offset using baseoffset = objoffset - deltaoffset. If a malicious packfile contains an OFSDELTA object where deltaoffset is 0, the calculation objoffset - 0 resolves back to the current object's own offset. Because the implementation lacks a depth counter, a "visited" set, or an explicit rejection of deltaoffset == 0, the resolver enters an infinite recursive loop, exhausting CPU resources and eventually crashing the process. Vulnerable Code Breakdown (dulwich/pack.py): Potential impact An attacker can trigger this infinite loop via any operation that walks packfiles (e.g., dulwich clone, fetch, cat-file, or internal Pack.getitem lookups). 1. CPU Exhaustion: The process will spin at 100% CPU indefinitely. 2. Denial of Service: Any service using…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-35mr-4567-66vg

  2. Revision 2 · amended ·

    Amended from osv record GHSA-35mr-4567-66vg

  3. Revision 1 · created ·

    Published from ghsa record GHSA-35mr-4567-66vg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114095

Advisory: Dulwich: Infinite Loop Denial of Service (DoS) in Packfile Object Resolution
IDs: CVE-2026-114095, GHSA-35mr-4567-66vg
Record: https://patchnext.com/advisories/ghsa-35mr-4567-66vg (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dulwich 1.2.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dulwich: affected < 1.2.9; fixed in 1.2.9

## Suggested inspection (read-only)
- `python -m pip show dulwich`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dulwich.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-35mr-4567-66vg (GitHub-reviewed advisory GHSA-35mr-4567-66vg lists affected ranges: PyPI dulwich >=0 <1.2.9)
- Verified: https://osv.dev/vulnerability/GHSA-35mr-4567-66vg (OSV record GHSA-35mr-4567-66vg lists affected ranges: PyPI dulwich >=0 <1.2.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…