Vulnerable OpenSSL included in sgx-dcap-quote-verify-python
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sgx-dcap-quote-verify-python 0.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sgx-dcap-quote-verify-python
- Affected
- < 0.0.3
- Fixed in
- 0.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-344m-qcjq-xgrf lists affected ranges: PyPI sgx-dcap-quote-verify-python >=0 <0.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-344m-qcjq-xgrf lists affected ranges: PyPI sgx-dcap-quote-verify-python >=0 <0.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
sgx-dcap-quote-verify-python includes a statically linked copy of OpenSSL. The version of OpenSSL included in sgx-dcap-quote-verify-python 0.0.1..0.0.2 is vulnerable to a security issue. More details about the OpenSSL vulnerabilities themselves can be found at https://www.openssl.org/news/secadv/20230207.txt. Analysis The binding includes OpenSSL version 1.1.1s which is vulnerable to the vulnerabilities disclosed in OpenSSL Security Advisory from the 7th February 2023. The binding does not directly use OpenSSL. The binding calls the SGX Quote Verification Library which uses OpenSSL. Explanation The SGX Quote Verification Library uses OpenSSL as a dependency to perform its cryptographic operations and certificate verification. The OpenSSL security advisory mentions multiple vulnerabilities but I believe the most concerning would be CVE-2023-0286 “X.400 address type confusion in X.509 GeneralName”. Its severity is rated high and the advisory states that “this vulnerability is most…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-344m-qcjq-xgrf
- Revision 1 · created ·
Published from osv record GHSA-344m-qcjq-xgrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-344m-qcjq-xgrf Advisory: Vulnerable OpenSSL included in sgx-dcap-quote-verify-python IDs: GHSA-344m-qcjq-xgrf Record: https://patchnext.com/advisories/ghsa-344m-qcjq-xgrf (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sgx-dcap-quote-verify-python 0.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sgx-dcap-quote-verify-python: affected < 0.0.3; fixed in 0.0.3 ## Suggested inspection (read-only) - `python -m pip show sgx-dcap-quote-verify-python`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sgx-dcap-quote-verify-python. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-344m-qcjq-xgrf (OSV record GHSA-344m-qcjq-xgrf lists affected ranges: PyPI sgx-dcap-quote-verify-python >=0 <0.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-344m-qcjq-xgrf (GitHub-reviewed advisory GHSA-344m-qcjq-xgrf lists affected ranges: PyPI sgx-dcap-quote-verify-python >=0 <0.0.3) Commands are suggestions: review each one before running it.
Loading voting…