Skip to content

← Actionable
Unratedamended

CLI does not correctly implement strict mode

GHSA-2xwp-m7mq-7q3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aws-encryption-sdk-cli 2.1.0, 1.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

In the affected versions, the AWS Encryption CLI operated in "discovery mode" even when "strict mode" was specified. Although decryption only succeeded if the user had permission to decrypt with at least one of the CMKs, decryption could be successful using a CMK that was not included in the user-defined set when the CLI was operating in "strict mode." Affected users should upgrade to Encryption CLI v1.8.x or v2.1.x as soon as possible.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2xwp-m7mq-7q3r

  2. Revision 1 · created ·

    Published from osv record GHSA-2xwp-m7mq-7q3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-2xwp-m7mq-7q3r

Advisory: CLI does not correctly implement strict mode
IDs: GHSA-2xwp-m7mq-7q3r
Record: https://patchnext.com/advisories/ghsa-2xwp-m7mq-7q3r (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aws-encryption-sdk-cli 2.1.0, 1.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aws-encryption-sdk-cli: affected < 1.8.0; >= 2.0.0, < 2.1.0; fixed in 1.8.0, 2.1.0

## Suggested inspection (read-only)
- `python -m pip show aws-encryption-sdk-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aws-encryption-sdk-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2xwp-m7mq-7q3r (OSV record GHSA-2xwp-m7mq-7q3r lists affected ranges: PyPI aws-encryption-sdk-cli >=0 =2.0.0 <2.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2xwp-m7mq-7q3r (GitHub-reviewed advisory GHSA-2xwp-m7mq-7q3r lists affected ranges: PyPI aws-encryption-sdk-cli >=0 =2.0.0 <2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…