ZendFramework1 Potential SQL injection in the ORDER implementation of Zend_Db_Select
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.12.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework1
- Affected
- >= 1.12.0, < 1.12.7
- Fixed in
- 1.12.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2x36-qhx3-7m5f lists affected ranges: Packagist zendframework/zendframework1 >=1.12.0 <1.12.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The implementation of the ORDER BY SQL statement in ZendDbSelect of Zend Framework 1 contains a potential SQL injection when the query string passed contains parentheses. For instance, the following code is affected by this issue: This code produce the string: instead of the correct one: The SQL injection occurs because we create a new ZendDbExpr() object, in presence of parentheses, passing directly the value without any filter on the string.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2x36-qhx3-7m5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2x36-qhx3-7m5f Advisory: ZendFramework1 Potential SQL injection in the ORDER implementation of Zend_Db_Select IDs: GHSA-2x36-qhx3-7m5f Record: https://patchnext.com/advisories/ghsa-2x36-qhx3-7m5f (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.12.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework1: affected >= 1.12.0, < 1.12.7; fixed in 1.12.7 ## Suggested inspection (read-only) - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2x36-qhx3-7m5f (GitHub-reviewed advisory GHSA-2x36-qhx3-7m5f lists affected ranges: Packagist zendframework/zendframework1 >=1.12.0 <1.12.7) Commands are suggestions: review each one before running it.
Loading voting…