A stored XSS in jaeger UI might allow an attacker who controls a trace to perform arbitrary jaeger queries
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jaegertracing/jaeger 1.47.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/jaegertracing/jaeger
- Affected
- < 1.47.0
- Fixed in
- 1.47.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2w8w-qhg4-f78j lists affected ranges: Go github.com/jaegertracing/jaeger >=0 <1.47.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Related UI vulnerability advisory: https://github.com/jaegertracing/jaeger-ui/security/advisories/GHSA-vv24-rm95-q56r Summary Jaeger UI is using the json-markup dependency to display span attributes and resources. This dependency is not sanitising keys of an object though, thus the KeyValuesTable is vulnerable to XSS. Details The vulnerable line is here: https://github.com/jaegertracing/jaeger-ui/blob/main/packages/jaeger-ui/src/components/TracePage/TraceTimelineViewer/SpanDetail/KeyValuesTable.tsx#L49 PoC 1. Start a Jaeger UI 2. Save the following trace as a file: 3. Upload that trace to Jaeger UI in order to visualise it. 4. Open the trace, open it's span's attributes. 5. XSS should be fired. Impact This is a XSS on Jaeger UI. XSS can be used to run JavaScript.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2w8w-qhg4-f78j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2w8w-qhg4-f78j Advisory: A stored XSS in jaeger UI might allow an attacker who controls a trace to perform arbitrary jaeger queries IDs: GHSA-2w8w-qhg4-f78j Record: https://patchnext.com/advisories/ghsa-2w8w-qhg4-f78j (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/jaegertracing/jaeger 1.47.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/jaegertracing/jaeger: affected < 1.47.0; fixed in 1.47.0 ## Suggested inspection (read-only) - Go github.com/jaegertracing/jaeger: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/jaegertracing/jaeger. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2w8w-qhg4-f78j (GitHub-reviewed advisory GHSA-2w8w-qhg4-f78j lists affected ranges: Go github.com/jaegertracing/jaeger >=0 <1.47.0) Commands are suggestions: review each one before running it.
Loading voting…