eZ Publish Legacy Cross-site Scripting (XSS) in 'disabled module' error template
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2018.9.1.2, 2018.6.1.3, 2017.12.4.2, 5.4.12.2, 5.3.12.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezpublish-legacy
- Affected
- >= 2018.9.0, < 2018.9.1.2>= 2018.6.0, < 2018.6.1.3>= 2011.0.0, < 2017.12.4.2>= 5.4.0, < 5.4.12.2>= 5.3.0, < 5.3.12.5
- Fixed in
- 5.3.12.5, 2018.6.1.3, 2018.9.1.2, 5.4.12.2, 2017.12.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2vh3-cj9j-mcj5 lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.9.0 =2018.6.0 =2011.0.0 =5.4.0 =5.3.0 <5.3.12.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy via the LegacyBridge. Installations where all modules are disabled may be vulnerable to XSS injection in the module name. This is a rare configuration, but we still recommend installing the update, which adds the necessary input washing. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/4697bff700e8cf95d5847ea19dad3479a77b02d9
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2vh3-cj9j-mcj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2vh3-cj9j-mcj5 Advisory: eZ Publish Legacy Cross-site Scripting (XSS) in 'disabled module' error template IDs: GHSA-2vh3-cj9j-mcj5 Record: https://patchnext.com/advisories/ghsa-2vh3-cj9j-mcj5 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2018.9.1.2, 2018.6.1.3, 2017.12.4.2, 5.4.12.2, 5.3.12.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezpublish-legacy: affected >= 2018.9.0, < 2018.9.1.2; >= 2018.6.0, < 2018.6.1.3; >= 2011.0.0, < 2017.12.4.2; >= 5.4.0, < 5.4.12.2; >= 5.3.0, < 5.3.12.5; fixed in 5.3.12.5, 2018.6.1.3, 2018.9.1.2, 5.4.12.2, 2017.12.4.2 ## Suggested inspection (read-only) - Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezpublish-legacy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2vh3-cj9j-mcj5 (GitHub-reviewed advisory GHSA-2vh3-cj9j-mcj5 lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.9.0 =2018.6.0 =2011.0.0 =5.4.0 =5.3.0 <5.3.12.5) Commands are suggestions: review each one before running it.
Loading voting…