jxl-oxide: integer subtraction overflow panic in cluster_from_table via crafted JXL input (DoS)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jxl-modular 0.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io jxl-modular
- Affected
- <= 0.11.2
- Fixed in
- 0.11.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2v8p-fqpx-2q3w lists affected ranges: crates.io jxl-modular >=0 <=0.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.2 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Logic bug in decodesimpletableslow may cause integer arithmetic overflow when decoding Modular image with certain kind of MA tree, which may panic with overflow-checks enabled. Impact Denial of service: any application passing untrusted JXL data to JxlImage::renderframe (or equivalent) can be crashed. Affects all builds with overflow checks enabled, which includes debug builds and any release build that sets overflow-checks = true in Cargo.toml or [profile.]. No memory corruption is possible — the panic fires before any unsafe code is reached.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2v8p-fqpx-2q3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2v8p-fqpx-2q3w Advisory: jxl-oxide: integer subtraction overflow panic in cluster_from_table via crafted JXL input (DoS) IDs: GHSA-2v8p-fqpx-2q3w Record: https://patchnext.com/advisories/ghsa-2v8p-fqpx-2q3w (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jxl-modular 0.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io jxl-modular: affected <= 0.11.2; fixed in 0.11.3 ## Suggested inspection (read-only) - crates.io jxl-modular: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jxl-modular. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2v8p-fqpx-2q3w (GitHub-reviewed advisory GHSA-2v8p-fqpx-2q3w lists affected ranges: crates.io jxl-modular >=0 <=0.11.2) Commands are suggestions: review each one before running it.
Loading voting…