Skip to content

← Actionable
High, CVSS 7.1amended

pnpm: pacquet trust-lockfile install can create dependency symlinks outside the project

GHSA-2rx9-3g3h-c2jv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 12.0.0-alpha.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    >= 12.0.0-alpha.0, < 12.0.0-alpha.5
    Fixed in
    12.0.0-alpha.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A crafted lockfile alias could reach several install-time filesystem joins. With --trust-lockfile or a frozen lockfile, traversal segments could create links outside the intended project or nodemodules boundary. This patch validates dependency names and every virtual-store slot before creating directories, links, bins, or hoisted entries. Security boundary - A shared safe-join helper rejects traversal, absolute, platform-specific, and reserved dependency names before filesystem materialization. - Direct and transitive dependency links, package links, bin destinations, and public/private hoist destinations use the same containment rule. - Global virtual-store slots validate the complete slot path, including version-derived components, before directory creation. - Snapshot slots and package names are checked before store initialization and before the current-lockfile fast path, closing the warm-install bypass. - Rejections preserve ERRPNPMINVALIDDEPENDENCYNAME. Exploit replay…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2rx9-3g3h-c2jv

  2. Revision 1 · created ·

    Published from osv record GHSA-2rx9-3g3h-c2jv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-2rx9-3g3h-c2jv

Advisory: pnpm: pacquet trust-lockfile install can create dependency symlinks outside the project
IDs: GHSA-2rx9-3g3h-c2jv
Record: https://patchnext.com/advisories/ghsa-2rx9-3g3h-c2jv (revision 2, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 12.0.0-alpha.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected >= 12.0.0-alpha.0, < 12.0.0-alpha.5; fixed in 12.0.0-alpha.5

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2rx9-3g3h-c2jv (OSV record GHSA-2rx9-3g3h-c2jv lists affected ranges: npm pnpm >=12.0.0-alpha.0 <12.0.0-alpha.5 (fixed))
- Verified: https://github.com/advisories/GHSA-2rx9-3g3h-c2jv (GitHub-reviewed advisory GHSA-2rx9-3g3h-c2jv lists affected ranges: npm pnpm >=12.0.0-alpha.0 <12.0.0-alpha.5)

Commands are suggestions: review each one before running it.

Loading voting…