engram: HTTP server CORS wildcard + auth-off-by-default enables CSRF graph exfiltration and persistent indirect prompt injection
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (engramx 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm engramx
- Affected
- < 2.0.2
- Fixed in
- 2.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2r2p-4cgf-hv7h lists affected ranges: npm engramx >=0 <2.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2r2p-4cgf-hv7h lists affected ranges: npm engramx >=0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The local HTTP server started by engram server (binding 127.0.0.1:7337 by default) was exposed to any browser origin with no authentication unless ENGRAMAPITOKEN was explicitly set. Combined with Access-Control-Allow-Origin: on every response and a body parser that did not require Content-Type: application/json, this allowed a malicious web page the developer visited to: 1. Exfiltrate the local knowledge graph via GET /query and GET /stats (function names, file layout, recorded decisions/mistakes). 2. Inject persistent prompt-injection payloads via POST /learn, which wrote mistake/decision nodes that were later surfaced as system-reminders to the user's AI coding agent on every future session and file edit. Severity: High — confidentiality + persistent indirect prompt injection against the user's coding agent. Affected versions engramx = 1.0.0, < 2.0.2 — any version that shipped the HTTP server. Patched in engramx@2.0.2 Workarounds (if you cannot upgrade) - Do not run engram…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2r2p-4cgf-hv7h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2r2p-4cgf-hv7h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2r2p-4cgf-hv7h Advisory: engram: HTTP server CORS wildcard + auth-off-by-default enables CSRF graph exfiltration and persistent indirect prompt injection IDs: GHSA-2r2p-4cgf-hv7h Record: https://patchnext.com/advisories/ghsa-2r2p-4cgf-hv7h (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: engramx 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm engramx: affected < 2.0.2; fixed in 2.0.2 ## Suggested inspection (read-only) - `npm ls engramx --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on engramx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2r2p-4cgf-hv7h (OSV record GHSA-2r2p-4cgf-hv7h lists affected ranges: npm engramx >=0 <2.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-2r2p-4cgf-hv7h (GitHub-reviewed advisory GHSA-2r2p-4cgf-hv7h lists affected ranges: npm engramx >=0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…