Skip to content

← Actionable
Medium, CVSS 5.9amended

Denial of Service in js-yaml

GHSA-2pr6-76vf-7546

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (js-yaml 3.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm js-yaml

    Affected
    < 3.13.0
    Fixed in
    3.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Versions of js-yaml prior to 3.13.0 are vulnerable to Denial of Service. By parsing a carefully-crafted YAML file, the node process stalls and may exhaust system resources leading to a Denial of Service. Recommendation Upgrade to version 3.13.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2pr6-76vf-7546

  2. Revision 1 · created ·

    Published from osv record GHSA-2pr6-76vf-7546

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-2pr6-76vf-7546

Advisory: Denial of Service in js-yaml
IDs: GHSA-2pr6-76vf-7546
Record: https://patchnext.com/advisories/ghsa-2pr6-76vf-7546 (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: js-yaml 3.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm js-yaml: affected < 3.13.0; fixed in 3.13.0

## Suggested inspection (read-only)
- `npm ls js-yaml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on js-yaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2pr6-76vf-7546 (OSV record GHSA-2pr6-76vf-7546 lists affected ranges: npm js-yaml >=0 <3.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-2pr6-76vf-7546 (GitHub-reviewed advisory GHSA-2pr6-76vf-7546 lists affected ranges: npm js-yaml >=0 <3.13.0)

Commands are suggestions: review each one before running it.

Loading voting…