Skip to content

← Actionable
High, CVSS 7.7

Sliver has Potential Zip Bomb Denial of Service in GzipEncoder

GHSA-2phg-qgmm-r638

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/BishopFox/sliver 1.7.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary GzipEncoder does not limit output size when processing compressed data. This allows unauthenticated remote attackers to crash sliver server by sending a http request with highly compressed gzip data (aka zip bomb). Details In util/encoders/gzip.go, Decode() method decompresses given data by reading the entire gzip buffer at once without limiting output size. PoC Impact Unauthenticated remote attackers can exhaust memory and cpu resource of sliver server and crash it when they have GzipEncoderID, which can be easily retrived from implant's http traffic, or by brute-forcing. A fixed version is available at https://github.com/BishopFox/sliver/releases/tag/v1.7.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2phg-qgmm-r638

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-2phg-qgmm-r638

Advisory: Sliver has Potential Zip Bomb Denial of Service in GzipEncoder
IDs: GHSA-2phg-qgmm-r638
Record: https://patchnext.com/advisories/ghsa-2phg-qgmm-r638 (revision 1, source checked 26 Oct 2026, 15:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/BishopFox/sliver 1.7.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/BishopFox/sliver: affected < 1.7.2; fixed in 1.7.2

## Suggested inspection (read-only)
- Go github.com/BishopFox/sliver: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/BishopFox/sliver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2phg-qgmm-r638 (GitHub-reviewed advisory GHSA-2phg-qgmm-r638 lists affected ranges: Go github.com/BishopFox/sliver >=0 <1.7.2)

Commands are suggestions: review each one before running it.

Loading voting…