personnummer/php vulnerable to Improper Input Validation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (personnummer/personnummer 3.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist personnummer/personnummer
- Affected
- < 3.0.2
- Fixed in
- 3.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2p6g-gjp8-ggg9 lists affected ranges: Packagist personnummer/personnummer >=0 <3.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
This vulnerability was reported to the personnummer team in June 2020. The slow response was due to locked ownership of some of the affected packages, which caused delays to update packages prior to disclosure. The vulnerability is determined to be low severity. Impact This vulnerability impacts users who rely on the for last digits of personnummer to be a real personnummer. Patches The issue have been patched in all repositories. The following versions should be updated to as soon as possible: C
3.0.2 D 3.0.1 Dart 3.0.3 Elixir 3.0.0 Go 3.0.1 Java 3.3.0 JavaScript 3.1.0 Kotlin 1.1.0 Lua 3.0.1 PHP 3.0.2 Perl 3.0.0 Python 3.0.2 Ruby 3.0.1 Rust 3.0.0 Scala 3.0.1 Swift 1.0.1 If you are using any of the earlier packages, please update to latest. Workarounds The issue arrieses from the regular expression allowing the first three digits in the last four digits of the personnummer to be 000, which is invalid. To mitigate this without upgrading, a check on the last four digits can be made to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2p6g-gjp8-ggg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2p6g-gjp8-ggg9 Advisory: personnummer/php vulnerable to Improper Input Validation IDs: GHSA-2p6g-gjp8-ggg9 Record: https://patchnext.com/advisories/ghsa-2p6g-gjp8-ggg9 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: personnummer/personnummer 3.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist personnummer/personnummer: affected < 3.0.2; fixed in 3.0.2 ## Suggested inspection (read-only) - Packagist personnummer/personnummer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on personnummer/personnummer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2p6g-gjp8-ggg9 (GitHub-reviewed advisory GHSA-2p6g-gjp8-ggg9 lists affected ranges: Packagist personnummer/personnummer >=0 <3.0.2) Commands are suggestions: review each one before running it.
Loading voting…