Rustls: TLS 1.3 handshake messages incorrectly accepted across encryption level boundaries
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rustls 0.23.45), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io rustls
- Affected
- >= 0.23.13, < 0.23.45
- Fixed in
- 0.23.45
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2mjx-qc3c-rqvc lists affected ranges: crates.io rustls >=0.23.13 <0.23.45 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record RUSTSEC-2026-0285 lists affected ranges: crates.io rustls >=0.23.13 <0.23.45 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mjx-qc3c-rqvc lists affected ranges: crates.io rustls >=0.23.13 <0.23.45
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Rustls accepted TLS 1.3 handshake messages sent at the wrong encryption level when they followed a key-changing message in the same record. The handshake transcript is still authenticated, so a network-position attacker cannot use this to alter or complete a handshake; the practical effect is that a peer could send handshake messages that should be encrypted in plaintext without rustls rejecting the connection. This issue affects rustls versions 0.23.13 through 0.23.44 inclusive.
Original report
Summary Rustls (tested version 0.23.44, and it appears still an issue on latest master though I have not tested this) accepts a TLS 1.3 server flight where a plaintext EncryptedExtensions is packed into the same record as the ServerHello. This is very similar to Go's CVE-2025-61730 fixed in https://github.com/golang/go/commit/5046bdf8a612b35a2c1a9e168054c1d5c65e7dd7
Details It appears `Deframer::aligned` considers itself aligned as long as all messages remaining in the buffer are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-2mjx-qc3c-rqvc
- Revision 4 · amended ·
Amended from ghsa record GHSA-2mjx-qc3c-rqvc
- Revision 3 · amended ·
Amended from ghsa record GHSA-2mjx-qc3c-rqvc
- Revision 2 · amended ·
Amended from osv record RUSTSEC-2026-0285
- Revision 1 · created ·
Published from osv record GHSA-2mjx-qc3c-rqvc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2mjx-qc3c-rqvc Advisory: Rustls: TLS 1.3 handshake messages incorrectly accepted across encryption level boundaries IDs: GHSA-2mjx-qc3c-rqvc Record: https://patchnext.com/advisories/ghsa-2mjx-qc3c-rqvc (revision 5, source checked 28 Oct 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rustls 0.23.45. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io rustls: affected >= 0.23.13, < 0.23.45; fixed in 0.23.45 ## Suggested inspection (read-only) - crates.io rustls: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rustls. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2mjx-qc3c-rqvc (OSV record GHSA-2mjx-qc3c-rqvc lists affected ranges: crates.io rustls >=0.23.13 <0.23.45 (fixed)) - Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0285 (OSV record RUSTSEC-2026-0285 lists affected ranges: crates.io rustls >=0.23.13 <0.23.45 (fixed)) - Verified: https://github.com/advisories/GHSA-2mjx-qc3c-rqvc (GitHub-reviewed advisory GHSA-2mjx-qc3c-rqvc lists affected ranges: crates.io rustls >=0.23.13 <0.23.45) Commands are suggestions: review each one before running it.
Loading voting…