skia-python vendors vulnerable libfreetype because of pinned cibuildwheel version
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI skia-python
- Affected
- >= 144.0, <= 144.0<= 138.0
- Fixed in
- 144.0.post1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2mhw-8qcg-gr96 lists affected ranges: PyPI skia-python >=144.0 =0 <144.0.post1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2mhw-8qcg-gr96 lists affected ranges: PyPI skia-python >=144.0 =0 <=138.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The Linux wheels for skia-python vendor a vulnerable version of libfreetype that is affected by CVE-2025-27363 [1]. The root cause is a chain of unfortunate events: 1. skia-python builds wheels using pinned pypa/cibuildwheel@2.21.3 [2] 2. cibuildwheel 2.21.3 in turn pins manylinux container images [3] 3. In these images, version 2.9.1-9.el8 of RedHat package freetype is preinstalled. This package version is vulnerable and has since been patched in 2.9.1-10. 4. During the skia-python Linux build, libfreetype is vendored from the system, resulting in skia-python.libs/libfreetype-29a7443c.so.6.16.1 [ To find the provenance of your vendored libfreetype, we extracted the 8-character hash of the original binary file that is added during the build process (29a7443c), and matched it against our database of hashes all historic Red Hat, Debian and Ubuntu releases of freetype. ] 5. Because freetype is only a transitive dependency of the packages explicitly installed by the build script…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2mhw-8qcg-gr96
- Revision 1 · created ·
Published from osv record GHSA-2mhw-8qcg-gr96
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2mhw-8qcg-gr96 Advisory: skia-python vendors vulnerable libfreetype because of pinned cibuildwheel version IDs: GHSA-2mhw-8qcg-gr96 Record: https://patchnext.com/advisories/ghsa-2mhw-8qcg-gr96 (revision 2, source checked 26 Oct 2026, 13:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: skia-python 144.0.post1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI skia-python: affected >= 144.0, <= 144.0; <= 138.0; fixed in 144.0.post1 ## Suggested inspection (read-only) - `python -m pip show skia-python`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on skia-python. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2mhw-8qcg-gr96 (OSV record GHSA-2mhw-8qcg-gr96 lists affected ranges: PyPI skia-python >=144.0 =0 <144.0.post1 (fixed)) - Verified: https://github.com/advisories/GHSA-2mhw-8qcg-gr96 (GitHub-reviewed advisory GHSA-2mhw-8qcg-gr96 lists affected ranges: PyPI skia-python >=144.0 =0 <=138.0) Commands are suggestions: review each one before running it.
Loading voting…