OpenCFP Framework (Sentry) Account takeover via null password reset codes
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cartalyst/sentry 2.1.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cartalyst/sentry
- Affected
- < 2.1.7
- Fixed in
- 2.1.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2m5g-8xpw-42vp lists affected ranges: Packagist cartalyst/sentry >=0 <2.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
OpenCFP, an open-source conference talk submission system written in PHP, contains a security vulnerability in its third-party authentication framework, Sentry, developed by Cartalyst. The vulnerability stems from how Sentry handles password reset checks. Users lacking a password reset token stored in the database default to having NULL in the resetpasswordcode column. Exploiting this flaw could allow unauthorized manipulation of any OpenCFP user's password, particularly those without an unused password reset token. Although successful login still requires correlating the numeric user ID with an email address, the identification of likely organizers (users 1-5) may facilitate this process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2m5g-8xpw-42vp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2m5g-8xpw-42vp Advisory: OpenCFP Framework (Sentry) Account takeover via null password reset codes IDs: GHSA-2m5g-8xpw-42vp Record: https://patchnext.com/advisories/ghsa-2m5g-8xpw-42vp (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cartalyst/sentry 2.1.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cartalyst/sentry: affected < 2.1.7; fixed in 2.1.7 ## Suggested inspection (read-only) - Packagist cartalyst/sentry: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cartalyst/sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2m5g-8xpw-42vp (GitHub-reviewed advisory GHSA-2m5g-8xpw-42vp lists affected ranges: Packagist cartalyst/sentry >=0 <2.1.7) Commands are suggestions: review each one before running it.
Loading voting…