Loofah has improper detection of disallowed URIs via allowed_uri?
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (loofah 2.25.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems loofah
- Affected
- >= 2.25.0, <= 2.25.0
- Fixed in
- 2.25.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2j22-pr5w-6gq8 lists affected ranges: RubyGems loofah >=2.25.0 <=2.25.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Loofah::HTML5::Scrub.alloweduri? does not correctly reject javascript: URIs when the scheme is split by HTML entity-encoded control characters such as (carriage return), (line feed), or 	 (tab). Details The alloweduri? method strips literal control characters before decoding HTML entities. Payloads like java script:alert(1) survive the control character strip, then is decoded to a carriage return, producing java\rscript:alert(1). Note that the Loofah sanitizer's default sanitize() path is not affected because Nokogiri decodes HTML entities during parsing before Loofah evaluates the URI protocol. This issue only affects direct callers of the alloweduri? string-level helper when passing HTML-encoded strings. Impact Applications that call Loofah::HTML5::Scrub.alloweduri? to validate user-controlled URLs and then render approved URLs into href or other browser-interpreted URI attributes may be vulnerable to cross-site scripting (XSS). This only affects…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2j22-pr5w-6gq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2j22-pr5w-6gq8 Advisory: Loofah has improper detection of disallowed URIs via `allowed_uri?` IDs: GHSA-2j22-pr5w-6gq8 Record: https://patchnext.com/advisories/ghsa-2j22-pr5w-6gq8 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: loofah 2.25.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems loofah: affected >= 2.25.0, <= 2.25.0; fixed in 2.25.1 ## Suggested inspection (read-only) - RubyGems loofah: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on loofah. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2j22-pr5w-6gq8 (GitHub-reviewed advisory GHSA-2j22-pr5w-6gq8 lists affected ranges: RubyGems loofah >=2.25.0 <=2.25.0) Commands are suggestions: review each one before running it.
Loading voting…