Silverstripe CSRF vulnerability in GridFieldAddExistingAutocompleter
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.3.0, 3.2.2, 3.1.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- <= 3.1.16>= 3.2.0, <= 3.2.1>= 3.3.0-beta1, <= 3.3.0-rc2
- Fixed in
- 3.3.0, 3.2.2, 3.1.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2hpc-mf4q-j885 lists affected ranges: Packagist silverstripe/framework >=0 =3.2.0 =3.3.0-beta1 <=3.3.0-rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
GridField does not have sufficient CSRF protection, meaning that in some cases users with CMS access can be tricked into posting unspecified data into the CMS from external websites. Amongst other default CMS interfaces, GridField is used for management of groups, users and permissions in the CMS. The resolution for this issue is to ensure that all gridFieldAlterAction submissions are checked for the SecurityID token during submission.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2hpc-mf4q-j885
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2hpc-mf4q-j885 Advisory: Silverstripe CSRF vulnerability in GridFieldAddExistingAutocompleter IDs: GHSA-2hpc-mf4q-j885 Record: https://patchnext.com/advisories/ghsa-2hpc-mf4q-j885 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.3.0, 3.2.2, 3.1.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected <= 3.1.16; >= 3.2.0, <= 3.2.1; >= 3.3.0-beta1, <= 3.3.0-rc2; fixed in 3.3.0, 3.2.2, 3.1.17 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2hpc-mf4q-j885 (GitHub-reviewed advisory GHSA-2hpc-mf4q-j885 lists affected ranges: Packagist silverstripe/framework >=0 =3.2.0 =3.3.0-beta1 <=3.3.0-rc2) Commands are suggestions: review each one before running it.
Loading voting…