Cross-Site Scripting in @hapi/boom
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@hapi/boom 0.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @hapi/boom
- Affected
- < 0.3.8
- Fixed in
- 0.3.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2ggq-vfcp-gwhj lists affected ranges: npm @hapi/boom >=0 <0.3.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2ggq-vfcp-gwhj lists affected ranges: npm @hapi/boom >=0 <0.3.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of @hapi/boom prior to 0.3.8 are vulnerable to Cross-Site Scripting (XSS). The package fails to properly escape error messages, which may allow attackers to execute arbitrary JavaScript in a victim's browser. Recommendation Upgrade to version 0.3.8 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2ggq-vfcp-gwhj
- Revision 1 · created ·
Published from osv record GHSA-2ggq-vfcp-gwhj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2ggq-vfcp-gwhj Advisory: Cross-Site Scripting in @hapi/boom IDs: GHSA-2ggq-vfcp-gwhj Record: https://patchnext.com/advisories/ghsa-2ggq-vfcp-gwhj (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @hapi/boom 0.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @hapi/boom: affected < 0.3.8; fixed in 0.3.8 ## Suggested inspection (read-only) - `npm ls @hapi/boom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @hapi/boom. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2ggq-vfcp-gwhj (OSV record GHSA-2ggq-vfcp-gwhj lists affected ranges: npm @hapi/boom >=0 <0.3.8 (fixed)) - Verified: https://github.com/advisories/GHSA-2ggq-vfcp-gwhj (GitHub-reviewed advisory GHSA-2ggq-vfcp-gwhj lists affected ranges: npm @hapi/boom >=0 <0.3.8) Commands are suggestions: review each one before running it.
Loading voting…