User enumeration in authentication mechanisms
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lexik/jwt-authentication-bundle 2.11.3, 2.10.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist lexik/jwt-authentication-bundle
- Affected
- < 2.10.7>= 2.11.0, < 2.11.3
- Fixed in
- 2.11.3, 2.10.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2frx-j9hj-6c65 lists affected ranges: Packagist lexik/jwt-authentication-bundle >=0 =2.11.0 <2.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Description ----------- The ability to enumerate users was possible without relevant permissions due to different exception messages depending on whether the user existed or not. Resolution ---------- We now ensure that a generic message is returned whether the user exists or not if the password is invalid or if the user does not exist. The patch for this issue is available here for branch 2.10.x and 2.x. Credits ------- I would like to thank James Isaac and Mathias Brodala for reporting the issue and Robin Chalas for fixing the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2frx-j9hj-6c65
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2frx-j9hj-6c65 Advisory: User enumeration in authentication mechanisms IDs: GHSA-2frx-j9hj-6c65 Record: https://patchnext.com/advisories/ghsa-2frx-j9hj-6c65 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lexik/jwt-authentication-bundle 2.11.3, 2.10.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist lexik/jwt-authentication-bundle: affected < 2.10.7; >= 2.11.0, < 2.11.3; fixed in 2.11.3, 2.10.7 ## Suggested inspection (read-only) - Packagist lexik/jwt-authentication-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lexik/jwt-authentication-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2frx-j9hj-6c65 (GitHub-reviewed advisory GHSA-2frx-j9hj-6c65 lists affected ranges: Packagist lexik/jwt-authentication-bundle >=0 =2.11.0 <2.11.3) Commands are suggestions: review each one before running it.
Loading voting…