Skip to content

← Actionable
Unrated

Laravel RCE vulnerability in "cookie" session driver

GHSA-2ffv-r4r9-r8xr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (illuminate/cookie 7.22.4, 6.18.31), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist illuminate/cookie

    Affected
    >= 4.1.0, < 6.18.31>= 7.0.0, < 7.22.4
    Fixed in
    6.18.31, 7.22.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Application's using the "cookie" session driver were the primary applications affected by this vulnerability. Since we have not yet released a security release for the Laravel 5.5 version of the framework, we recommend that all applications running Laravel 5.5 and earlier do not use the "cookie" session driver in their production deployments. Regarding the vulnerability, applications using the "cookie" session driver that were also exposing an encryption oracle via their application were vulnerable to remote code execution. An encryption oracle is a mechanism where arbitrary user input is encrypted and the encrypted string is later displayed or exposed to the user. This combination of scenarios lets the user generate valid Laravel signed encryption strings for any plain-text string, thus allowing them to craft Laravel session payloads when an application is using the "cookie" driver. This fix prefixes cookie values with an HMAC hash of the cookie's name before encryption and then…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2ffv-r4r9-r8xr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-2ffv-r4r9-r8xr

Advisory: Laravel RCE vulnerability in "cookie" session driver
IDs: GHSA-2ffv-r4r9-r8xr
Record: https://patchnext.com/advisories/ghsa-2ffv-r4r9-r8xr (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: illuminate/cookie 7.22.4, 6.18.31. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist illuminate/cookie: affected >= 4.1.0, < 6.18.31; >= 7.0.0, < 7.22.4; fixed in 6.18.31, 7.22.4

## Suggested inspection (read-only)
- Packagist illuminate/cookie: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on illuminate/cookie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2ffv-r4r9-r8xr (GitHub-reviewed advisory GHSA-2ffv-r4r9-r8xr lists affected ranges: Packagist illuminate/cookie >=4.1.0 =7.0.0 <7.22.4)

Commands are suggestions: review each one before running it.

Loading voting…