Passbolt API Stored XSS on first/last name during setup
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (passbolt/passbolt_api 2.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist passbolt/passbolt_api
- Affected
- < 2.11.0
- Fixed in
- 2.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2f46-4xjm-73x5 lists affected ranges: Packagist passbolt/passbolt_api >=0 <2.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Description An administrator can craft a user with a malicious first name and last name, using a payload such as The user will then receive the invitation email and click on the setup link. The setup start page served by the server will fire the XSS. Impact of issue An administrator could use this exploit to edit the setup start page for a given user, for example, trick the user into installing another extension. Even though the severity of this issue in itself is high, the likelihood is low because the exploit will be visible in clear by the user in the email notification, and also requires an action from a malicious administrator. Fix Sanitize the firstname and lastname in the page that is used to trigger the extension setup process. Additionally since v2.11 some default CSP are inserted in the server response headers to prevent inline-scripts or 3rd party domain scripts on pages served by the passbolt API. This is to cater for the case where the administrator has not set them up…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2f46-4xjm-73x5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2f46-4xjm-73x5 Advisory: Passbolt API Stored XSS on first/last name during setup IDs: GHSA-2f46-4xjm-73x5 Record: https://patchnext.com/advisories/ghsa-2f46-4xjm-73x5 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: passbolt/passbolt_api 2.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist passbolt/passbolt_api: affected < 2.11.0; fixed in 2.11.0 ## Suggested inspection (read-only) - Packagist passbolt/passbolt_api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on passbolt/passbolt_api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2f46-4xjm-73x5 (GitHub-reviewed advisory GHSA-2f46-4xjm-73x5 lists affected ranges: Packagist passbolt/passbolt_api >=0 <2.11.0) Commands are suggestions: review each one before running it.
Loading voting…