Skip to content

← Actionable
Unrated

Incorrect handling of credential expiry by /nats-io/nats-server

GHSA-2c64-vj8g-vwrq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/nats-io/nats-server/v2 2.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

(This advisory is canonically https://advisories.nats.io/CVE/CVE-2020-26892.txt ) Problem Description NATS nats-server through 2020-10-07 has Incorrect Access Control because of how expired credentials are handled. The NATS accounts system has expiration timestamps on credentials; the <https://github.com/nats-io/jwt library had an API which encouraged misuse and an IsRevoked() method which misused its own API. A new IsClaimRevoked() method has correct handling and the nats-server has been updated to use this. The old IsRevoked() method now always returns true and other client code will have to be updated to avoid calling it. The CVE identifier should cover any application using the old JWT API, where the nats-server is one of those applications. Affected versions JWT library all versions prior to 1.1.0 fixed after nats-io/jwt PR 103 landed (2020-10-06) NATS Server Version 2 prior to 2.1.9 + 2.0.0 through and including 2.1.8 are vulnerable. fixed with nats-io/nats-server PRs 1632,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2c64-vj8g-vwrq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-2c64-vj8g-vwrq

Advisory: Incorrect handling of credential expiry by /nats-io/nats-server
IDs: GHSA-2c64-vj8g-vwrq
Record: https://patchnext.com/advisories/ghsa-2c64-vj8g-vwrq (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/nats-io/nats-server/v2 2.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/nats-io/nats-server/v2: affected < 2.1.9; fixed in 2.1.9

## Suggested inspection (read-only)
- Go github.com/nats-io/nats-server/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/nats-io/nats-server/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2c64-vj8g-vwrq (GitHub-reviewed advisory GHSA-2c64-vj8g-vwrq lists affected ranges: Go github.com/nats-io/nats-server/v2 >=0 <2.1.9)

Commands are suggestions: review each one before running it.

Loading voting…