Skip to content

← Actionable
Medium, CVSS 4.0

C5 Firefly III CSV Injection.

GHSA-29w6-c52g-m8jc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (grumpydictator/firefly-iii 6.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary CSV injection is a vulnerability where untrusted user input in CSV files can lead to unauthorized access or data manipulation. In my subsequent testing of the application. Details I discovered that there is an option to "Export Data" from the web app to your personal computer, which exports a "csv" file that can be opened with Excel software that supports macros. P.S I discovered that the web application's is offering a demo-site that anyone may access to play with the web application. So, there's a chance that someone will export the data (CVS) from the demo site and execute it on their PC, giving the malicious actor a complete control over their machine. (if a user enters a malicious payload to the website). PoC You can check out my vulnerability report if you need more details/PoC with screenshots: (removed by JC5) Impact An attacker can exploit this by entering a specially crafted payload to one of the fields, and when a user export the csv file using the "Export Data"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-29w6-c52g-m8jc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-29w6-c52g-m8jc

Advisory: C5 Firefly III CSV Injection.
IDs: GHSA-29w6-c52g-m8jc
Record: https://patchnext.com/advisories/ghsa-29w6-c52g-m8jc (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: grumpydictator/firefly-iii 6.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist grumpydictator/firefly-iii: affected < 6.1.7; fixed in 6.1.7

## Suggested inspection (read-only)
- Packagist grumpydictator/firefly-iii: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on grumpydictator/firefly-iii.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-29w6-c52g-m8jc (GitHub-reviewed advisory GHSA-29w6-c52g-m8jc lists affected ranges: Packagist grumpydictator/firefly-iii >=0 <6.1.7)

Commands are suggestions: review each one before running it.

Loading voting…