OpenZeppelin Confidential Contracts VestingWalletConfidential: a malicious ERC-7984 token is able to extract private data from the vesting wallet
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/confidential-contracts 0.5.2, 0.4.2, 0.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @openzeppelin/confidential-contracts
- Affected
- < 0.3.2>= 0.4.0-rc.0, < 0.4.2>= 0.5.0-rc.0, < 0.5.2
- Fixed in
- 0.5.2, 0.3.2, 0.4.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29h2-jr22-frmh lists affected ranges: npm @openzeppelin/confidential-contracts >=0 =0.4.0-rc.0 =0.5.0-rc.0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-29h2-jr22-frmh lists affected ranges: npm @openzeppelin/confidential-contracts >=0 =0.4.0-rc.0 =0.5.0-rc.0 <0.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Two locations consume an encrypted handle returned by an untrusted external party and use it without verifying that the party is ACL-authorized on it. VestingWalletConfidential Malicious users can call release with a malicious token. This token could return an alternative handle on confidentialBalanceOf, which represents the balance of the vesting wallet on an alternative ERC-7984 token (or any other handle that the vesting wallet has access to). The vesting wallet does not check that the token has ACL access and grants access to a new handle derived from the returned handle. Effectively, this bug allows a malicious user to gain information about any private euint64 handle that the vesting wallet has access to via a malicious ERC-7984 token. There is no loss of funds. ERC7984 On a transfer with callback, ERC7984 uses the ebool returned by the recipient's IERC7984Receiver.onConfidentialTransferReceived to drive the refund logic, without checking that the recipient has ACL…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-29h2-jr22-frmh
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-29h2-jr22-frmh
- Revision 1 · created ·
Published from ghsa record GHSA-29h2-jr22-frmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-29h2-jr22-frmh Advisory: OpenZeppelin Confidential Contracts `VestingWalletConfidential`: a malicious ERC-7984 token is able to extract private data from the vesting wallet IDs: GHSA-29h2-jr22-frmh Record: https://patchnext.com/advisories/ghsa-29h2-jr22-frmh (revision 4, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/confidential-contracts 0.5.2, 0.4.2, 0.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @openzeppelin/confidential-contracts: affected < 0.3.2; >= 0.4.0-rc.0, < 0.4.2; >= 0.5.0-rc.0, < 0.5.2; fixed in 0.5.2, 0.3.2, 0.4.2 ## Suggested inspection (read-only) - `npm ls @openzeppelin/confidential-contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @openzeppelin/confidential-contracts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-29h2-jr22-frmh (GitHub-reviewed advisory GHSA-29h2-jr22-frmh lists affected ranges: npm @openzeppelin/confidential-contracts >=0 =0.4.0-rc.0 =0.5.0-rc.0 <0.5.2) - Verified: https://osv.dev/vulnerability/GHSA-29h2-jr22-frmh (OSV record GHSA-29h2-jr22-frmh lists affected ranges: npm @openzeppelin/confidential-contracts >=0 =0.4.0-rc.0 =0.5.0-rc.0 <0.5.2 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…