OpenSearch Data Prepper uses deprecated SSL protocol identifier
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.dataprepper.plugins:geoip-processor 2.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.opensearch.dataprepper.plugins:geoip-processor
- Affected
- >= 2.4.0, < 2.12.2
- Fixed in
- 2.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-28gg-8qqj-fhh5 lists affected ranges: Maven org.opensearch.dataprepper.plugins:geoip-processor >=2.4.0 <2.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The GeoIP processor and Kafka source and buffer were using the deprecated "SSL" protocol identifier when creating SSL contexts, potentially allowing the use of insecure SSL protocols instead of modern TLS versions. Multiple Data Prepper plugins used SSLContext.getInstance("SSL") which could potentially allow the use of deprecated SSL protocols (SSLv2, SSLv3) that have known security vulnerabilities. While modern Java implementations typically default to secure TLS versions even with the "SSL" identifier, explicitly using "TLS" ensures that only secure TLS protocols are negotiated. The affected components were: GeoIP Processor: The DBSource.initiateSSL() method used for downloading GeoIP databases from external sources Kafka Plugin: Both CustomClientSslEngineFactory and InsecureSslEngineFactory classes used for Kafka client connections This could potentially allow connections to negotiate weaker SSL protocols instead of enforcing modern TLS versions, reducing the security of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-28gg-8qqj-fhh5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-28gg-8qqj-fhh5 Advisory: OpenSearch Data Prepper uses deprecated SSL protocol identifier IDs: GHSA-28gg-8qqj-fhh5 Record: https://patchnext.com/advisories/ghsa-28gg-8qqj-fhh5 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.opensearch.dataprepper.plugins:geoip-processor 2.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.opensearch.dataprepper.plugins:geoip-processor: affected >= 2.4.0, < 2.12.2; fixed in 2.12.2 ## Suggested inspection (read-only) - Maven org.opensearch.dataprepper.plugins:geoip-processor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.opensearch.dataprepper.plugins:geoip-processor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-28gg-8qqj-fhh5 (GitHub-reviewed advisory GHSA-28gg-8qqj-fhh5 lists affected ranges: Maven org.opensearch.dataprepper.plugins:geoip-processor >=2.4.0 <2.12.2) Commands are suggestions: review each one before running it.
Loading voting…