Skip to content

← Actionable
Medium, CVSS 4.9

Shopware exposes sensitive user information via CSV export mapping

GHSA-27c9-vp3w-6ww8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/core 6.7.3.1, 6.6.10.7; shopware/platform 6.7.3.1, 6.6.10.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist shopware/core

    Affected
    >= 6.7.0.0, < 6.7.3.1< 6.6.10.7
    Fixed in
    6.7.3.1, 6.6.10.7
  • Packagist shopware/platform

    Affected
    >= 6.7.0.0, < 6.7.3.1< 6.6.10.7
    Fixed in
    6.7.3.1, 6.6.10.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Malicious actors can exploit this finding to export sensitive customer information from a Shopware application, including password hashes and password reset tokens. In SaaS deployments, this primarily affects customer accounts. In on-premise deployments, however, it also includes the hashes and recovery tokens of administrator-level accounts, which increases the potential impact. This risk is noteworthy because users may reuse the same or similar passwords across different services. In such cases, exposed hashes could allow attackers to recover credentials that might also be valid outside of Shopware. Description Sensitive information disclosure occurs when an application inadvertently displays sensitive information to its users. Depending on the context, websites can leak all kinds of information including: • Data regarding other users, such as usernames and/or e-mail addresses • Sensitive commercial data such as customer names • Technical details about the website and/or the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-27c9-vp3w-6ww8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-27c9-vp3w-6ww8

Advisory: Shopware exposes sensitive user information via CSV export mapping
IDs: GHSA-27c9-vp3w-6ww8
Record: https://patchnext.com/advisories/ghsa-27c9-vp3w-6ww8 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shopware/core 6.7.3.1, 6.6.10.7; shopware/platform 6.7.3.1, 6.6.10.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist shopware/core: affected >= 6.7.0.0, < 6.7.3.1; < 6.6.10.7; fixed in 6.7.3.1, 6.6.10.7
- Packagist shopware/platform: affected >= 6.7.0.0, < 6.7.3.1; < 6.6.10.7; fixed in 6.7.3.1, 6.6.10.7

## Suggested inspection (read-only)
- Packagist shopware/core: check the installed version with your package manager.
- Packagist shopware/platform: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shopware/core, shopware/platform.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-27c9-vp3w-6ww8 (GitHub-reviewed advisory GHSA-27c9-vp3w-6ww8 lists affected ranges: Packagist shopware/platform >=6.7.0.0 =0 =6.7.0.0 =0 <6.6.10.7)

Commands are suggestions: review each one before running it.

Loading voting…