Gradio's dropdown component pre-process step does not limit the values to those in the dropdown list
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gradio 5.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gradio
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-26jh-r8g2-6fpr lists affected ranges: PyPI gradio >=0 <5.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-26jh-r8g2-6fpr lists affected ranges: PyPI gradio >=0 <5.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? This vulnerability is a data validation issue in the Gradio Dropdown component's pre-processing step. Even if the allowcustomvalue parameter is set to False, attackers can bypass this restriction by sending custom requests with arbitrary values, effectively breaking the developer’s intended input constraints. While this alone is not a severe vulnerability, it can lead to more critical security issues, particularly when paired with other vulnerabilities like file downloads from the user's machine. Patches Yes, this issue is addressed in gradio=5.0. Please upgrade to the latest version to resolve the problem. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? To mitigate the issue without upgrading, developers can add manual validation in their prediction function to check the received values against the allowed dropdown values before processing them.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-26jh-r8g2-6fpr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-26jh-r8g2-6fpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-26jh-r8g2-6fpr Advisory: Gradio's dropdown component pre-process step does not limit the values to those in the dropdown list IDs: GHSA-26jh-r8g2-6fpr Record: https://patchnext.com/advisories/ghsa-26jh-r8g2-6fpr (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gradio 5.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gradio: affected < 5.0.0; fixed in 5.0.0 ## Suggested inspection (read-only) - `python -m pip show gradio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gradio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-26jh-r8g2-6fpr (OSV record GHSA-26jh-r8g2-6fpr lists affected ranges: PyPI gradio >=0 <5.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-26jh-r8g2-6fpr (GitHub-reviewed advisory GHSA-26jh-r8g2-6fpr lists affected ranges: PyPI gradio >=0 <5.0.0) Commands are suggestions: review each one before running it.
Loading voting…