Next.js: Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.4.1, 15.5.28), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 10.0.0, <= 15.5.27>= 16.0.0, <= 16.4.0
- Fixed in
- 16.4.1, 15.5.28
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2464-fhr4-w9xw lists affected ranges: npm next >=10.0.0 =16.0.0 <=16.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2464-fhr4-w9xw lists affected ranges: npm next >=10.0.0 =16.0.0 <16.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A memory-related vulnerability has been discovered in an upstream library used for Image Optimization can lead to possible remote code execution (RCE) when Next.js runs on glibc-based Linux. Workaround Ensure the version of sharp used by Next.js is greater than or equal to 0.35.5. Fresh installs automatically get a fixed version of sharp. Upgrading Next.js to the patched versions will ensure package managers automatically provide a fixed version of sharp to Next.js.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from ghsa record GHSA-2464-fhr4-w9xw
- Revision 4 · amended ·
Amended from ghsa record GHSA-2464-fhr4-w9xw
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-2464-fhr4-w9xw
- Revision 1 · created ·
Published from ghsa record GHSA-2464-fhr4-w9xw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-2464-fhr4-w9xw Advisory: Next.js: Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used IDs: GHSA-2464-fhr4-w9xw Record: https://patchnext.com/advisories/ghsa-2464-fhr4-w9xw (revision 5, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 16.4.1, 15.5.28. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 10.0.0, <= 15.5.27; >= 16.0.0, <= 16.4.0; fixed in 16.4.1, 15.5.28 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2464-fhr4-w9xw (GitHub-reviewed advisory GHSA-2464-fhr4-w9xw lists affected ranges: npm next >=10.0.0 =16.0.0 <=16.4.0) - Verified: https://osv.dev/vulnerability/GHSA-2464-fhr4-w9xw (OSV record GHSA-2464-fhr4-w9xw lists affected ranges: npm next >=10.0.0 =16.0.0 <16.4.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…