Skip to content

← Actionable
Unrated

wasmvm: Malicious smart contract can crash the chain

GHSA-23qp-3c2m-xx6w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/CosmWasm/wasmvm/v2 2.2.2, 2.1.5, 2.0.6; github.com/CosmWasm/wasmvm 1.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

CWA-2025-001 Severity Medium (Moderate + Likely)[^1] Affected versions: - wasmvm = 2.2.0, < 2.2.2 - wasmvm = 2.1.0, < 2.1.5 - wasmvm = 2.0.0, < 2.0.6 - wasmvm < 1.5.8 Patched versions: - wasmvm 1.5.8, 2.0.6, 2.1.5, 2.2.2 Description of the bug The vulnerability can be used to crash the chain. The underlying bug that causes this is present on both permissioned and premissionless chains, but it can only be triggered reliably with a malicious contract, so permissioned chains are much less likely to be affected. (We'll add more detail once chains had a chance to upgrade.) Patch - 1.5: https://github.com/CosmWasm/wasmvm/commit/1151bc6df7d02d1889b8da37cf8510eaf4198eea - 2.0: https://github.com/CosmWasm/wasmvm/commit/d4ff2adee44e6b9f7415a5dfbb3de745ab9b7678 - 2.1: https://github.com/CosmWasm/wasmvm/commit/8d44a286fabc793a2fba93752e58cd0fd5b88a2d - 2.2: https://github.com/CosmWasm/wasmvm/commit/0aefa4c378457aeb3c07e7975b875be38872c56d Applying the patch The patch will be shipped in releases…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-23qp-3c2m-xx6w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-23qp-3c2m-xx6w

Advisory: wasmvm: Malicious smart contract can crash the chain
IDs: GHSA-23qp-3c2m-xx6w
Record: https://patchnext.com/advisories/ghsa-23qp-3c2m-xx6w (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/CosmWasm/wasmvm/v2 2.2.2, 2.1.5, 2.0.6; github.com/CosmWasm/wasmvm 1.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/CosmWasm/wasmvm/v2: affected >= 2.0.0, < 2.0.6; >= 2.1.0, < 2.1.5; >= 2.2.0, < 2.2.2; fixed in 2.0.6, 2.1.5, 2.2.2
- Go github.com/CosmWasm/wasmvm: affected < 1.5.8; fixed in 1.5.8

## Suggested inspection (read-only)
- Go github.com/CosmWasm/wasmvm/v2: check the installed version with your package manager.
- Go github.com/CosmWasm/wasmvm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/CosmWasm/wasmvm/v2, github.com/CosmWasm/wasmvm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-23qp-3c2m-xx6w (GitHub-reviewed advisory GHSA-23qp-3c2m-xx6w lists affected ranges: Go github.com/CosmWasm/wasmvm >=0 =2.0.0 =2.1.0 =2.2.0 <2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…