Skip to content

← Actionable
Medium, CVSS 6.5amended

Scrapy allows redirect following in protocols other than HTTP

GHSA-23j4-mw76-5v7h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (scrapy 2.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI scrapy

    Affected
    < 2.11.2
    Fixed in
    2.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Scrapy was following redirects regardless of the URL protocol, so redirects were working for data://, file://, ftp://, s3://, and any other scheme defined in the DOWNLOADHANDLERS setting. However, HTTP redirects should only work between URLs that use the http:// or https:// schemes. A malicious actor, given write access to the start requests (e.g. ability to define starturls) of a spider and read access to the spider output, could exploit this vulnerability to: - Redirect to any local file using the file:// scheme to read its contents. - Redirect to an ftp:// URL of a malicious FTP server to obtain the FTP username and password configured in the spider or project. - Redirect to any s3:// URL to read its content using the S3 credentials configured in the spider or project. For file:// and s3://, how the spider implements its parsing of input data into an output item determines what data would be vulnerable. A spider that always outputs the entire contents of a response would be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-23j4-mw76-5v7h

  2. Revision 1 · created ·

    Published from osv record GHSA-23j4-mw76-5v7h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-23j4-mw76-5v7h

Advisory: Scrapy allows redirect following in protocols other than HTTP
IDs: GHSA-23j4-mw76-5v7h
Record: https://patchnext.com/advisories/ghsa-23j4-mw76-5v7h (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: scrapy 2.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI scrapy: affected < 2.11.2; fixed in 2.11.2

## Suggested inspection (read-only)
- `python -m pip show scrapy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on scrapy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-23j4-mw76-5v7h (OSV record GHSA-23j4-mw76-5v7h lists affected ranges: PyPI scrapy >=0 <2.11.2 (fixed))
- Verified: https://github.com/advisories/GHSA-23j4-mw76-5v7h (GitHub-reviewed advisory GHSA-23j4-mw76-5v7h lists affected ranges: PyPI scrapy >=0 <2.11.2)

Commands are suggestions: review each one before running it.

Loading voting…