webauthn-rs-core/webauthn-authenticator-rs: Origin validation mismatch possible when subdomains are allowed
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (webauthn-rs-core 0.6.1-dev, 0.5.5; webauthn-authenticator-rs 0.6.1-dev, 0.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io webauthn-rs-core
- Affected
- <= 0.5.4>= 0.6.0-dev, <= 0.6.0-dev
- Fixed in
- 0.6.1-dev, 0.5.5
crates.io webauthn-authenticator-rs
- Affected
- >= 0.6.0-dev, <= 0.6.0-dev<= 0.5.4
- Fixed in
- 0.6.1-dev, 0.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-22w3-693w-x895 lists affected ranges: crates.io webauthn-rs-core >=0 =0.6.0-dev =0.6.0-dev =0 <=0.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary webauthn-rs-core ([Relying Party][rp]) and webauthn-authenticator-rs ([client][]) checked that [an Origin in CollectedClientData][origin] is valid for [an RP ID][rpid] with [str::endswith()][ends-with], [without checking for a dot (.) before the RP ID when allowing subdomains][registerable-suffix]. This check is flawed, and could allow requests from an attacker-controlled domain such as hermit-crab.example to be accepted for the RP ID crab.example (assuming .example was publicly-registerable TLD) when the RP allows authenticating from a subdomain (disabled by default in webauthn-rs-core and webauthn-rs). [registerable-suffix]: https://html.spec.whatwg.org/multipage/browsers.html#is-a-registrable-domain-suffix-of-or-is-equal-to [ends-with]: https://doc.rust-lang.org/stable/std/primitive.str.html#method.endswith [client]: https://www.w3.org/TR/webauthn-3/#client [rp]: https://www.w3.org/TR/webauthn-3/#relying-party [rpid]: https://www.w3.org/TR/webauthn-3/#rp-id [origin]:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-22w3-693w-x895
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-22w3-693w-x895 Advisory: webauthn-rs-core/webauthn-authenticator-rs: Origin validation mismatch possible when subdomains are allowed IDs: GHSA-22w3-693w-x895 Record: https://patchnext.com/advisories/ghsa-22w3-693w-x895 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: webauthn-rs-core 0.6.1-dev, 0.5.5; webauthn-authenticator-rs 0.6.1-dev, 0.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io webauthn-rs-core: affected <= 0.5.4; >= 0.6.0-dev, <= 0.6.0-dev; fixed in 0.6.1-dev, 0.5.5 - crates.io webauthn-authenticator-rs: affected >= 0.6.0-dev, <= 0.6.0-dev; <= 0.5.4; fixed in 0.6.1-dev, 0.5.5 ## Suggested inspection (read-only) - crates.io webauthn-rs-core: check the installed version with your package manager. - crates.io webauthn-authenticator-rs: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on webauthn-rs-core, webauthn-authenticator-rs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-22w3-693w-x895 (GitHub-reviewed advisory GHSA-22w3-693w-x895 lists affected ranges: crates.io webauthn-rs-core >=0 =0.6.0-dev =0.6.0-dev =0 <=0.5.4) Commands are suggestions: review each one before running it.
Loading voting…