Skip to content

← Actionable
Low, CVSS 2.2

OpenSearch vulnerable to improper authorization for Rollover Requests

GHSA-22vx-2x23-98w6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opensearch.plugin:opensearch-security 3.2.0.0, 2.19.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description A flaw was identified in the OpenSearch Security plugin's handling of index rollover requests. When a rollover request included an explicit target index name, the security plugin did not properly evaluate access control permissions against the target index. This could allow a user with rollover permissions on a source index to create a new index with a name they are not authorized to use. Impact A user with indices:admin/rollover permission on a source index pattern could roll over to a target index name outside their authorized index patterns. This is limited to index creation via the rollover API and requires the user to already have rollover privileges on the source index. Patches This issue is fixed in OpenSearch 2.19.4 and 3.2.0 Workarounds Grant the indices:admin/rollover permission only to fully trusted users.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-22vx-2x23-98w6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-22vx-2x23-98w6

Advisory: OpenSearch vulnerable to improper authorization for Rollover Requests
IDs: GHSA-22vx-2x23-98w6
Record: https://patchnext.com/advisories/ghsa-22vx-2x23-98w6 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opensearch.plugin:opensearch-security 3.2.0.0, 2.19.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opensearch.plugin:opensearch-security: affected >= 1.0.0, <= 2.19.3; >= 3.0.0, <= 3.1.0; fixed in 2.19.4.0, 3.2.0.0

## Suggested inspection (read-only)
- Maven org.opensearch.plugin:opensearch-security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opensearch.plugin:opensearch-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-22vx-2x23-98w6 (GitHub-reviewed advisory GHSA-22vx-2x23-98w6 lists affected ranges: Maven org.opensearch.plugin:opensearch-security >=1.0.0 =3.0.0 <=3.1.0)

Commands are suggestions: review each one before running it.

Loading voting…