Skip to content

← Actionable
High, CVSS 8.6

libgit2-sys affected by memory corruption, denial of service, and arbitrary code execution in libgit2

GHSA-22q8-ghmq-63vf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (libgit2-sys 0.16.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The libgit2 project fixed three security issues in the 1.7.2 release. These issues are: The gitrevparsesingle function can potentially enter an infinite loop on a well-crafted input, potentially causing a Denial of Service. This function is exposed in the git2 crate via the Repository::revparsesingle method. The gitindexadd function may cause heap corruption and possibly lead to arbitrary code execution. This function is exposed in the git2 crate via the Index::add method. The smart transport negotiation may experience an out-of-bounds read when a remote server did not advertise capabilities. The libgit2-sys crate bundles libgit2, or optionally links to a system libgit2 library. In either case, versions of the libgit2 library less than 1.7.2 are vulnerable. The 0.16.2 release of libgit2-sys bundles the fixed version of 1.7.2, and requires a system libgit2 version of at least 1.7.2. It is recommended that all users upgrade.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-22q8-ghmq-63vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-22q8-ghmq-63vf

Advisory: libgit2-sys affected by memory corruption, denial of service, and arbitrary code execution in libgit2
IDs: GHSA-22q8-ghmq-63vf
Record: https://patchnext.com/advisories/ghsa-22q8-ghmq-63vf (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: libgit2-sys 0.16.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io libgit2-sys: affected < 0.16.2; fixed in 0.16.2

## Suggested inspection (read-only)
- crates.io libgit2-sys: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on libgit2-sys.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-22q8-ghmq-63vf (GitHub-reviewed advisory GHSA-22q8-ghmq-63vf lists affected ranges: crates.io libgit2-sys >=0 <0.16.2)

Commands are suggestions: review each one before running it.

Loading voting…