Skip to content

← Actionable
Medium, CVSS 5.3amended

GraphQL Armor Max-Depth Plugin Bypass via fragment caching

GHSA-224p-v68g-5g8f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@escape.tech/graphql-armor-max-depth 2.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A query depth restriction using the max-depth can be bypassed if ignoreIntrospection is enabled (which is the default configuration) by naming your query/fragment schema. Details In the countDepth function, we have the following code that calculates the depth of a used fragment: which will calculate the depth of the fragment used in the current node, store the value in this.visitedFragments and re-use it in the future to avoid re-calculating the depth for the same fragment. The issue arises when the same fragment is used multiple times, at different depths. The current caching takes into account the depth of the first occurrence, which means if the fragment is re-used later in a higher depth, this cached value is not updated. So, for example, sending the following query with a max depth of 6: The first use of Test fragment does not exceed the defined limit, and this depth will be cached. In the second use, the fragment is reused in a greater depth, but the countDepth function…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-224p-v68g-5g8f

  2. Revision 1 · created ·

    Published from osv record GHSA-224p-v68g-5g8f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-224p-v68g-5g8f

Advisory: GraphQL Armor Max-Depth Plugin Bypass via fragment caching
IDs: GHSA-224p-v68g-5g8f
Record: https://patchnext.com/advisories/ghsa-224p-v68g-5g8f (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @escape.tech/graphql-armor-max-depth 2.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @escape.tech/graphql-armor-max-depth: affected <= 2.4.1; fixed in 2.4.2

## Suggested inspection (read-only)
- `npm ls @escape.tech/graphql-armor-max-depth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @escape.tech/graphql-armor-max-depth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-224p-v68g-5g8f (OSV record GHSA-224p-v68g-5g8f lists affected ranges: npm @escape.tech/graphql-armor-max-depth >=0 <2.4.2 (fixed))
- Verified: https://github.com/advisories/GHSA-224p-v68g-5g8f (GitHub-reviewed advisory GHSA-224p-v68g-5g8f lists affected ranges: npm @escape.tech/graphql-armor-max-depth >=0 <=2.4.1)

Commands are suggestions: review each one before running it.

Loading voting…