Skip to content

← Actionable
Unrated

DRUPAL-CORE-2026-013

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.4.7, 11.3.17, 10.6.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 10.5.0, < 10.6.17>= 11.0.0, < 11.3.17>= 11.4.0, < 11.4.7
    Fixed in
    10.6.17, 11.3.17, 11.4.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The Drupal project uses the CKEditor library for WYSIWYG editing. CKEditor has released a security update that impacts Drupal. Vulnerabilities are possible if Drupal is configured to use CKEditor for WYSIWYG editing. An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit this Cross-Site Scripting (XSS) vulnerability to target users with access to the WYSIWYG CKEditor, including site admins with privileged access. For more information, see CKEditor's security advisory: * High-severity Cross-site scripting (XSS) in the engine package

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record DRUPAL-CORE-2026-013

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: drupal-core-2026-013

Advisory: DRUPAL-CORE-2026-013
IDs: drupal-core-2026-013
Record: https://patchnext.com/advisories/drupal-core-2026-013 (revision 1, source checked 23 Oct 2026, 22:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.4.7, 11.3.17, 10.6.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 10.5.0, < 10.6.17; >= 11.0.0, < 11.3.17; >= 11.4.0, < 11.4.7; fixed in 10.6.17, 11.3.17, 11.4.7

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/DRUPAL-CORE-2026-013 (OSV record DRUPAL-CORE-2026-013 lists affected ranges: Packagist drupal/core >=10.5.0 =11.0.0 =11.4.0 <11.4.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…