Mautic has Stored Cross-Site Scripting (XSS) in Projects Component
CVE-2026-9809GHSA-7h65-whp7-rgqf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 7.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 7.0.0, < 7.1.2
- Fixed in
- 7.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7h65-whp7-rgqf lists affected ranges: Packagist mautic/core >=7.0.0 <7.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:H/A:N
- EPSS
- CVE-2026-9809: 0.21% estimated exploitation activity in the next 30 days; percentile 11.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored Cross-Site Scripting (XSS) vulnerability exists in the Projects component of Mautic 7. When displaying project tags and popovers on administrative detail views (such as campaigns, emails, or forms), user-supplied project names are rendered without proper sanitization. An authenticated user with permissions to create or edit projects can exploit this to inject malicious script payloads. Impact When an administrative user views an entity associated with a compromised project and hovers over its tag, the injected script executes within the context of their active browser session. This could allow an attacker to perform administrative actions on behalf of the victim, alter system configurations, or exfiltrate sensitive data. Patched Versions This security issue has been addressed in the following release: 7.1.2 Note: Mautic 6.x, 5.x, and 4.x branches do not contain the Projects feature and are not affected by this vulnerability. For general security support regarding…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7h65-whp7-rgqf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9809 Advisory: Mautic has Stored Cross-Site Scripting (XSS) in Projects Component IDs: CVE-2026-9809, GHSA-7h65-whp7-rgqf Record: https://patchnext.com/advisories/cve-2026-9809 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 7.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 7.0.0, < 7.1.2; fixed in 7.1.2 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7h65-whp7-rgqf (GitHub-reviewed advisory GHSA-7h65-whp7-rgqf lists affected ranges: Packagist mautic/core >=7.0.0 <7.1.2) Commands are suggestions: review each one before running it.
Loading voting…