Skip to content

← Actionable
High, CVSS 7.5amended

kin-openapi: Nil-pointer dereference panic in openapi3filter for OpenAPI 3.1 array schemas missing items

CVE-2026-97394GHSA-p6wj-qrr4-pgh5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/getkin/kin-openapi 0.143.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-97394: 0.61% estimated exploitation activity in the next 30 days; percentile 49.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A nil-pointer dereference in openapi3filter lets any unauthenticated client crash a request handler with a single HTTP request against an OpenAPI 3.1 operation that declares type: array without items. OpenAPI 3.1 (JSON Schema 2020-12) permits omitting items, and doc.Validate() accepts such schemas with Schema.Items == nil. Request/response decoders then dereference Items with no nil check. The panic is deterministic (100%) on every request to the affected operation. There is no recover() in openapi3filter; under handlers without per-request recover the process can exit. Details Spec-validation asymmetry. OpenAPI 3.0 rejects array schemas that omit items (openapi3/schema.go around the TypeArray / newSchemaItemsRequired branch). For OpenAPI 3.1, T.Validate enables jsonSchema2020ValidationEnabled, so that check is skipped and Schema.Items remains nil after a clean doc.Validate(). Vulnerable decoder. The primary request-side crash is in UrlencodedBodyDecoder (still present on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p6wj-qrr4-pgh5

  2. Revision 1 · created ·

    Published from osv record GHSA-p6wj-qrr4-pgh5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-97394

Advisory: kin-openapi: Nil-pointer dereference panic in openapi3filter for OpenAPI 3.1 array schemas missing items
IDs: CVE-2026-97394, GHSA-p6wj-qrr4-pgh5
Record: https://patchnext.com/advisories/cve-2026-97394 (revision 2, source checked 26 Oct 2026, 15:32 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/getkin/kin-openapi 0.143.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/getkin/kin-openapi: affected >= 0.136.0, < 0.143.0; fixed in 0.143.0

## Suggested inspection (read-only)
- Go github.com/getkin/kin-openapi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/getkin/kin-openapi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p6wj-qrr4-pgh5 (OSV record GHSA-p6wj-qrr4-pgh5 lists affected ranges: Go github.com/getkin/kin-openapi >=0.136.0 <0.143.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p6wj-qrr4-pgh5 (GitHub-reviewed advisory GHSA-p6wj-qrr4-pgh5 lists affected ranges: Go github.com/getkin/kin-openapi >=0.136.0 <0.143.0)

Commands are suggestions: review each one before running it.

Loading voting…