Skip to content

← Actionable
UnratedExploited · CISA KEVamended

Integer Overflow or Wraparound in GitLab

CVE-2026-97229

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitlab 19.4.2, 19.3.5, 19.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami gitlab

    Affected
    >= 19.2.0, < 19.2.8>= 19.3.0, < 19.3.5>= 19.4.0, < 19.4.2
    Fixed in
    19.2.8, 19.3.5, 19.4.2

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
not scored
EPSS
  • CVE-2026-97229: 27.69% estimated exploitation activity in the next 30 days; percentile 98.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2026-97229 (date added 2026-10-29). Customer workflow unchanged.

  2. Revision 1 · created ·

    Published from osv record BIT-gitlab-2026-97229

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-97229

Advisory: Integer Overflow or Wraparound in GitLab
IDs: CVE-2026-97229
Record: https://patchnext.com/advisories/cve-2026-97229 (revision 2, source checked 31 Oct 2026, 07:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: gitlab 19.4.2, 19.3.5, 19.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami gitlab: affected >= 19.2.0, < 19.2.8; >= 19.3.0, < 19.3.5; >= 19.4.0, < 19.4.2; fixed in 19.2.8, 19.3.5, 19.4.2

## Suggested inspection (read-only)
- Bitnami gitlab: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitlab.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-gitlab-2026-97229 (OSV record BIT-gitlab-2026-97229 lists affected ranges: Bitnami gitlab >=19.2.0 =19.3.0 =19.4.0 <19.4.2 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2026-97229 to the Known Exploited Vulnerabilities catalog on 2026-10-29.)

Commands are suggestions: review each one before running it.

Loading voting…