pretix vulnerable to Authorization Bypass Through User-Controlled Key
CVE-2026-9712GHSA-72p9-6vv6-gvqh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2026.4.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pretix
- Affected
- < 2026.4.2
- Fixed in
- 2026.4.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-72p9-6vv6-gvqh lists affected ranges: PyPI pretix >=0 <2026.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72p9-6vv6-gvqh lists affected ranges: PyPI pretix >=0 <2026.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 3.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-9712: 0.22% estimated exploitation activity in the next 30 days; percentile 12.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When creating an export through the pretix API, API clients are returned an UUID value for their export job (a long, random string like 35742818-c375-4d15-839f-d49aecce94d6). Using this UUID, the API client can then request the actual file for download. The same kind of UUID is used in other places in pretix when temporary files are generated for internal use or download. One remaining API endpoint, however, wrongfully did not verify if the UUID used for download actually belongs to a file that is supposed to be downloadable and belongs to the correct user. In reality, this is hard to exploit because an attacker would need to have access to a valid UUID for the file they desire which is unlikely to happen without a separate security problem giving them access to logs etc.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-72p9-6vv6-gvqh
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-72p9-6vv6-gvqh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9712 Advisory: pretix vulnerable to Authorization Bypass Through User-Controlled Key IDs: CVE-2026-9712, GHSA-72p9-6vv6-gvqh Record: https://patchnext.com/advisories/cve-2026-9712 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pretix 2026.4.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pretix: affected < 2026.4.2; fixed in 2026.4.2 ## Suggested inspection (read-only) - `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pretix. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-72p9-6vv6-gvqh (OSV record GHSA-72p9-6vv6-gvqh lists affected ranges: PyPI pretix >=0 <2026.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-72p9-6vv6-gvqh (GitHub-reviewed advisory GHSA-72p9-6vv6-gvqh lists affected ranges: PyPI pretix >=0 <2026.4.2) Commands are suggestions: review each one before running it.
Loading voting…