undici vulnerable to TLS certificate validation bypass via dropped requestTls in SOCKS5 ProxyAgent
CVE-2026-9697GHSA-vmh5-mc38-953g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.5.0, 7.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- >= 7.23.0, < 7.28.0>= 8.0.0, < 8.5.0
- Fixed in
- 7.28.0, 8.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmh5-mc38-953g lists affected ranges: npm undici >=7.23.0 =8.0.0 <8.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmh5-mc38-953g lists affected ranges: npm undici >=7.23.0 =8.0.0 <8.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-9697: 0.46% estimated exploitation activity in the next 30 days; percentile 39.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's ProxyAgent silently drops the requestTls option when configured with a SOCKS5 proxy URI (socks5:// or socks://). The target HTTPS connection through the SOCKS5 tunnel falls back to Node's default trust store, ignoring user-configured ca, cert, key, rejectUnauthorized, and servername settings. Applications that pin to an internal or corporate CA via requestTls.ca will, when their proxy URI is SOCKS5, get the default Mozilla CA bundle as the trust anchor instead. Any cert signed by any publicly-trusted CA for the target hostname is accepted, breaking the intended pin and enabling MITM read and tamper of the HTTPS exchange. Affected applications are those that use undici's ProxyAgent (or Socks5ProxyAgent directly) with SOCKS5 AND rely on requestTls for TLS scope restriction. The bug was introduced in undici 7.23.0 when SOCKS5 support was added. Patches Upgrade to undici v7.28.0 or v8.5.0. Workarounds No workaround is available within the SOCKS5 path. If a SOCKS5 proxy…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vmh5-mc38-953g
- Revision 1 · created ·
Published from osv record GHSA-vmh5-mc38-953g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9697 Advisory: undici vulnerable to TLS certificate validation bypass via dropped requestTls in SOCKS5 ProxyAgent IDs: CVE-2026-9697, GHSA-vmh5-mc38-953g Record: https://patchnext.com/advisories/cve-2026-9697 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.5.0, 7.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected >= 7.23.0, < 7.28.0; >= 8.0.0, < 8.5.0; fixed in 7.28.0, 8.5.0 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vmh5-mc38-953g (OSV record GHSA-vmh5-mc38-953g lists affected ranges: npm undici >=7.23.0 =8.0.0 <8.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vmh5-mc38-953g (GitHub-reviewed advisory GHSA-vmh5-mc38-953g lists affected ranges: npm undici >=7.23.0 =8.0.0 <8.5.0) Commands are suggestions: review each one before running it.
Loading voting…