Skip to content

← Actionable
High, CVSS 7.8amended

Librsvg: Use-after-free when XML includes have duplicated entities

CVE-2026-96889GHSA-cpvr-w4j5-2mpg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (librsvg 2.63.2, 2.62.4, 2.61.5, 2.60.3, 2.57.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io librsvg

    Affected
    < 2.57.5>= 2.60.0-beta.0, < 2.60.3>= 2.61.0, < 2.61.5>= 2.62.0-beta.0, < 2.62.4>= 2.63.0-beta.0, < 2.63.2
    Fixed in
    2.62.4, 2.57.5, 2.61.5, 2.60.3, 2.63.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-96889: 0.56% estimated exploitation activity in the next 30 days; percentile 46.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Librsvg uses libxml2, a C library, to parse XML. When librsvg parses an SVG document which has a nested Xinclude, an XML entity declaration with a duplicate name as an existing one can cause a use-after-free error. While libxml2 is expanding an internal entity, a recursive XInclude can parse another document that declares an entity with the same name. Both parses use the same XmlState entity map on the librsvg side. entityinsert() replaces the first entry, whose Drop implementation calls xmlFreeNode(). The outer xmlCtxtParseEntity() then keeps using the freed 144-byte xmlEntity. The included parse should not free an entity that the outer parser is still using. The fix is in commit 8a1b0cd319e9af2d1e9cf878081dd77f227a0504, where librsvg will no longer free xmlEntity pointers that libxml2 is still using.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-cpvr-w4j5-2mpg

  2. Revision 3 · amended ·

    Amended from ghsa record GHSA-cpvr-w4j5-2mpg

  3. Revision 2 · amended ·

    Amended from osv record RUSTSEC-2026-0305

  4. Revision 1 · created ·

    Published from osv record GHSA-cpvr-w4j5-2mpg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96889

Advisory: Librsvg: Use-after-free when XML includes have duplicated entities
IDs: CVE-2026-96889, GHSA-cpvr-w4j5-2mpg
Record: https://patchnext.com/advisories/cve-2026-96889 (revision 4, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: librsvg 2.63.2, 2.62.4, 2.61.5, 2.60.3, 2.57.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io librsvg: affected < 2.57.5; >= 2.60.0-beta.0, < 2.60.3; >= 2.61.0, < 2.61.5; >= 2.62.0-beta.0, < 2.62.4; >= 2.63.0-beta.0, < 2.63.2; fixed in 2.62.4, 2.57.5, 2.61.5, 2.60.3, 2.63.2

## Suggested inspection (read-only)
- crates.io librsvg: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on librsvg.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cpvr-w4j5-2mpg (OSV record GHSA-cpvr-w4j5-2mpg lists affected ranges: crates.io librsvg >=0 =2.60.0-beta.0 =2.61.0 =2.62.0-beta.0 =2.63.0-beta.0 <2.63.2 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0305 (OSV record RUSTSEC-2026-0305 lists affected ranges: crates.io librsvg >=0.0.0-0 =2.57.90 =2.61.0 =2.61.90 =2.62.90 <2.63.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cpvr-w4j5-2mpg (GitHub-reviewed advisory GHSA-cpvr-w4j5-2mpg lists affected ranges: crates.io librsvg >=0 =2.60.0-beta.0 =2.61.0 =2.62.0-beta.0 =2.63.0-beta.0 <2.63.2)

Commands are suggestions: review each one before running it.

Loading voting…