undici vulnerable to HTTP header injection via Set-Cookie percent-decoding
CVE-2026-9679GHSA-p88m-4jfj-68fv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.5.0, 7.28.0, 6.27.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm undici
- Affected
- < 6.27.0>= 7.0.0, < 7.28.0>= 8.0.0, < 8.5.0
- Fixed in
- 6.27.0, 7.28.0, 8.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p88m-4jfj-68fv lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p88m-4jfj-68fv lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-9679: 0.26% estimated exploitation activity in the next 30 days; percentile 17.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici's cookie parser in parseSetCookie percent-decodes cookie values via qsUnescape, turning encoded sequences like %0D%0A, %00, %3B, and %3D into their literal byte equivalents. RFC 6265 §5.4 does not specify any decoding and browsers do not decode either. Applications that parse a Set-Cookie header and then forward the parsed value into a response header (proxies, middleware, SSR frameworks) become vulnerable to HTTP response header injection: an attacker-controlled upstream can inject arbitrary Set-Cookie, Location, or Cache-Control headers into the application's downstream response, enabling session fixation, open redirect, or cache poisoning. Affected applications are those that use undici's cookie parsing (parseSetCookie, parseCookie, getSetCookies) and forward the parsed cookie value into a response header. This was introduced in undici 7.0.0 via #3789. Patches Upgrade to undici v6.27.0, v7.28.0 or v8.5.0. Workarounds If upgrade is not immediately possible, do not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p88m-4jfj-68fv
- Revision 1 · created ·
Published from osv record GHSA-p88m-4jfj-68fv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-9679 Advisory: undici vulnerable to HTTP header injection via Set-Cookie percent-decoding IDs: CVE-2026-9679, GHSA-p88m-4jfj-68fv Record: https://patchnext.com/advisories/cve-2026-9679 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: undici 8.5.0, 7.28.0, 6.27.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm undici: affected < 6.27.0; >= 7.0.0, < 7.28.0; >= 8.0.0, < 8.5.0; fixed in 6.27.0, 7.28.0, 8.5.0 ## Suggested inspection (read-only) - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p88m-4jfj-68fv (OSV record GHSA-p88m-4jfj-68fv lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-p88m-4jfj-68fv (GitHub-reviewed advisory GHSA-p88m-4jfj-68fv lists affected ranges: npm undici >=0 =7.0.0 =8.0.0 <8.5.0) Commands are suggestions: review each one before running it.
Loading voting…