Skip to content

← Actionable
High, CVSS 8.2amended

figlet is vulnerable to denial of service via unbounded loop when whitespaceBreak is used with a small width

CVE-2026-96780GHSA-62ch-8vmq-8xm7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (figlet 1.11.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm figlet

    Affected
    < 1.11.3
    Fixed in
    1.11.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-96780: 0.50% estimated exploitation activity in the next 30 days; percentile 42.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial-of-service (infinite loop) can occur in text() / textSync() when both: - whitespaceBreak: true is set, and - width is set smaller than the rendered width of a single FIGlet character. Under these conditions breakWord() could never find a valid break point, so the word-wrapping loop in generateFigTextLines() never terminated. This pins a CPU core and grows memory without bound, blocking the Node.js event loop. Severity Low or Medium. Triggering requires a non-default configuration (whitespaceBreak: true) and an attacker-controlled width value reaching text()/textSync(). This library is typically used with fixed options, where this is not reachable. Applications that pass an untrusted width together with whitespaceBreak on a request path are affected. Patches Fixed in figlet 1.11.3. breakWord() now always makes forward progress (emitting an over-wide character on its own line), and FIGlet header parsing now rejects invalid values (e.g. zero/negative height). Workarounds…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-62ch-8vmq-8xm7

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-62ch-8vmq-8xm7

  4. Revision 1 · created ·

    Published from ghsa record GHSA-62ch-8vmq-8xm7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96780

Advisory: figlet is vulnerable to denial of service via unbounded loop when whitespaceBreak is used with a small width
IDs: CVE-2026-96780, GHSA-62ch-8vmq-8xm7
Record: https://patchnext.com/advisories/cve-2026-96780 (revision 4, source checked 26 Oct 2026, 13:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: figlet 1.11.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm figlet: affected < 1.11.3; fixed in 1.11.3

## Suggested inspection (read-only)
- `npm ls figlet --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on figlet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-62ch-8vmq-8xm7 (GitHub-reviewed advisory GHSA-62ch-8vmq-8xm7 lists affected ranges: npm figlet >=0 <1.11.3)
- Verified: https://osv.dev/vulnerability/GHSA-62ch-8vmq-8xm7 (OSV record GHSA-62ch-8vmq-8xm7 lists affected ranges: npm figlet >=0 <1.11.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…