Skip to content

← Actionable
Critical, CVSS 9.1amended

Authlib: empty signatures validation in JWS JSON deserialization

CVE-2026-96760GHSA-6v38-4h7w-rj9h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI authlib

    Affected
    < 1.9.0
    Fixed in
    1.9.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-96760: 0.43% estimated exploitation activity in the next 30 days; percentile 37.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Authlib (prior to 1.9.0) contains a signature verification bypass vulnerability. The JsonWebSignature.deserialize_json() method accepts a JSON Serialization JWS object and returns the payload as successfully verified without checking for a signature and without requiring a cryptographic key.

Root cause `authlib/jose/rfc7515/jws.py`, read on the installed 1.8.0 artifact: ```python is_valid = True

set before anything is checked for header_obj in obj["signatures"]:

empty array means the body never runs jws_header, valid = self._validate_json_jws(...) if not valid: is_valid = False ... if is_valid: return rv

returns the payload as verified ``` `is_valid` is initialised to `True` and only ever set to `False` from inside the loop. A JWS JSON Serialization object whose `signatures` array is empty iterates zero times, so the flag survives and the payload is returned as successfully verified. No key is consulted, because no signature is examined.

Reproduction ```python import…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-6v38-4h7w-rj9h

  2. Revision 1 · created ·

    Published from ghsa record GHSA-6v38-4h7w-rj9h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-96760

Advisory: Authlib: empty signatures validation in JWS JSON deserialization
IDs: CVE-2026-96760, GHSA-6v38-4h7w-rj9h
Record: https://patchnext.com/advisories/cve-2026-96760 (revision 2, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlib 1.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI authlib: affected < 1.9.0; fixed in 1.9.0

## Suggested inspection (read-only)
- `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6v38-4h7w-rj9h (OSV record GHSA-6v38-4h7w-rj9h lists affected ranges: PyPI authlib >=0 <1.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-6v38-4h7w-rj9h (GitHub-reviewed advisory GHSA-6v38-4h7w-rj9h lists affected ranges: PyPI authlib >=0 <=1.8.0)

Commands are suggestions: review each one before running it.

Loading voting…