Skip to content

← Actionable
High, CVSS 7.5amended

undici WebSocket client vulnerable to denial of service via cumulative fragment bypass

CVE-2026-9675GHSA-38rv-x7px-6hhq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (undici 8.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm undici

    Affected
    >= 8.0.0, < 8.5.0
    Fixed in
    8.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-9675: 0.43% estimated exploitation activity in the next 30 days; percentile 36.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The undici WebSocket client enforces maxPayloadSize per-frame but does not enforce the cumulative size of fragmented uncompressed messages. A malicious WebSocket server can stream many small fragments that each pass per-frame validation but collectively exceed the configured limit, causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service. Affected applications are those using the undici WebSocket client (new WebSocket(...)) that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint. This is a regression specific to undici 8.1.0. The 6.25.0 line shipped the equivalent cumulative check from the start and is unaffected. The 7.x line never had the maxPayloadSize feature and is also unaffected. Patches Upgrade to undici = 8.5.0. Workarounds No workaround is available. The fix must be applied through an upgrade.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-38rv-x7px-6hhq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-38rv-x7px-6hhq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-38rv-x7px-6hhq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-9675

Advisory: undici WebSocket client vulnerable to denial of service via cumulative fragment bypass
IDs: CVE-2026-9675, GHSA-38rv-x7px-6hhq
Record: https://patchnext.com/advisories/cve-2026-9675 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: undici 8.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm undici: affected >= 8.0.0, < 8.5.0; fixed in 8.5.0

## Suggested inspection (read-only)
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-38rv-x7px-6hhq (GitHub-reviewed advisory GHSA-38rv-x7px-6hhq lists affected ranges: npm undici >=8.0.0 <8.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-38rv-x7px-6hhq (OSV record GHSA-38rv-x7px-6hhq lists affected ranges: npm undici >=8.0.0 <8.5.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…